Download

Date Download Size Verification
2016/12/18   neard-1.0.22.7z 181.15 MB [MD5] [SHA1] [SHA256] [SHA512]
2016/12/18   neard-1.0.22.zip 424.05 MB [MD5] [SHA1] [SHA256] [SHA512]

Changelog

  • Cannot switch to trace verbosity (Issue #198)
  • Apache PATH env mixed with LocalSystem env (Issue #193)
  • Dissociate Apache and SVN (Issue #168)
  • Use latest OpenSSL release to generate SSL certificate (Issue #167)
  • Forgetting Memcached switch version impl (Issue #164)
  • Port undefined error for MailHog service (Issue #163)
  • 30% CPU usage for 2 minutes while generating SSL certificate (Issue #161)
  • Can’t switch PostgreSQL version (Issue #160)
  • Bug while enable binary (Issue #156)
  • Add Ruby tool (Issue #154)
  • Add Python tool (Issue #98)
  • Add Perl, Vbs and Python CGI scripts examples
  • Bug while setting version in neard.conf
  • Downgrade default Filezilla bundle to 0.9.42 (XP compatibility)
  • Implement enable on tools and apps
  • Integration of Codacy and Travis

Upgrade from previous release

  • required : Remove file alias\svn.conf
  • required : Copy folder bin\svn
  • required : Remove then replace folder core
  • required : Move folders inside svnrepos to bin\svn\svn1.7.19\repos
  • required : Remove folder svnrepos
  • required : Copy folder tools\python
  • required : Copy folder tools\ruby
  • required : Remove folder tools\svn
  • required : Add line pythonVersion = "2.7.12.3" after phpunitVersion in neard.conf
  • required : Add line rubyVersion = "2.0.0.p648" after pythonVersion in neard.conf
  • required : Remove line svnVersion in the tools part in neard.conf
  • required : Add line svnVersion = "1.7.19" after memcachedEnable in neard.conf
  • required : Add line svnEnable = "1" after svnVersion in neard.conf
  • required : Remove then replace file sprites.dat
  • required : Remove files ssl\neardfilezilla.*
  • required : Replace your existing Apache version with the latest Apache bundle.
  • required : Replace your existing Filezilla version with the latest Filezilla bundle.