About

PHP : a server-side scripting language designed for web development including PEAR and extra extensions.

Installation

  • Download and install Neard.
  • If you already have installed Neard, stop it.
  • Download a PHP version of your choice.
  • Extract archive in neard\bins\php\. Directory structure example :
[-] neard
  | [-] bins
  |  | [-] php
  |  |  | [-] php5.2.17
  |  |     | neard.conf
  • Start Neard.
  • Switch to the PHP version you have extracted on Neard :

If you have the warning icon on your PHP version, you will have to switch the Apache version first.

OpenSSL

PHP version OpenSSL version
5.2.17 0.9.8
5.3.x 0.9.8
5.4.x 0.9.8
5.5.x 1.0.1
5.6.0 > 5.6.26 1.0.1
5.6.28 > 5.6.x 1.0.2
7.0.x 1.0.2
7.1.x 1.0.2
7.2.x 1.1.0

Additionnal extensions

  PHP 5.2.x PHP 5.3.x PHP 5.4.x PHP 5.5.x PHP 5.6.x PHP 7.0.x PHP 7.1.x PHP 7.2.x
php_apc
php_imagick
php_memcache
php_mongo
php_mongodb
php_ssh2
php_vld

PEAR

PEAR is integrated in each PHP module through the install-pear-nozlib.phar standalone installer.

PEAR version PHP 5.2.x PHP 5.3.x PHP 5.4+
1.7.2
1.9.5
1.10.1
1.10.5

Apache compatibility table

  Apache 2.2.x Apache 2.4.x
PHP 5.2.x
PHP 5.3.x
PHP 5.4.x
PHP 5.5.x
PHP 5.6.x
PHP 7.0.x
PHP 7.1.x
PHP 7.2.x

MongoDB compatibility table

PHP 5.3 and 5.4 includes the old php_mongo extension that is not compatible with MongoDB 3.2+.
More infos : https://docs.mongodb.com/ecosystem/drivers/php

  MongoDB 2.6 MongoDB 3.0 MongoDB 3.2+
PHP 5.2.x
PHP 5.3.x
PHP 5.4.x
PHP 5.5.x
PHP 5.6.x
PHP 7.0.x
PHP 7.1.x
PHP 7.2.x

ImageMagick and Imagick extension

  Compiled with ImageMagick Using ImageMagick library
Imagick 3.3.0 6.8.9-1 Q16 x86 2014-05-08 6.8.9-1 Q16 x86 2014-05-08
Imagick 3.4.3RC1 6.8.9-1 Q16 x86 2014-05-08 6.8.9-1 Q16 x86 2014-05-08
Imagick 3.4.3 6.9.3-7 Q16 x86 2016-03-27 6.9.3-7 Q16 x86 2016-03-27

Releases

: Default
: Pre-release

Version Official date Module date Neard Download Verification
7.2.0RC6 2017/11/08 2017/11/20 >= 1.3 neard-php-7.2.0RC6-r22.7z [MD5] [SHA1] [SHA256] [SHA512]
7.2.0RC1 2017/08/29 2017/09/03 >= 1.3 neard-php-7.2.0RC1-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.1.11 2017/10/26 2017/11/20 >= 1.0.16 neard-php-7.1.11-r22.7z [MD5] [SHA1] [SHA256] [SHA512]
7.1.9 2017/08/30 2017/09/03 >= 1.0.16 neard-php-7.1.9-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.1.8 2017/08/02 2017/09/03 >= 1.0.16 neard-php-7.1.8-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.1.7 2017/07/06 2017/09/03 >= 1.0.16 neard-php-7.1.7-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.1.5 2017/05/09 2017/09/03 >= 1.0.16 neard-php-7.1.5-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.1.3 2017/03/16 2017/09/03 >= 1.0.16 neard-php-7.1.3-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.1.2 2017/02/14 2017/09/03 >= 1.0.16 neard-php-7.1.2-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.1.0 2016/12/02 2017/09/03 >= 1.0.16 neard-php-7.1.0-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.25 2017/10/25 2017/11/20 >= 1.0.16 neard-php-7.0.25-r22.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.23 2017/08/29 2017/09/03 >= 1.0.16 neard-php-7.0.23-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.22 2017/08/02 2017/09/03 >= 1.0.16 neard-php-7.0.22-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.21 2017/07/05 2017/09/03 >= 1.0.16 neard-php-7.0.21-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.19 2017/05/09 2017/09/03 >= 1.0.16 neard-php-7.0.19-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.17 2017/03/16 2017/09/03 >= 1.0.16 neard-php-7.0.17-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.16 2017/02/14 2017/09/03 >= 1.0.16 neard-php-7.0.16-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.14 2016/12/07 2017/09/03 >= 1.0.16 neard-php-7.0.14-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.13 2016/11/09 2017/09/03 >= 1.0.16 neard-php-7.0.13-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.11 2016/09/14 2017/09/03 >= 1.0.16 neard-php-7.0.11-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.8 2016/06/22 2017/09/03 >= 1.0.16 neard-php-7.0.8-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.7 2016/05/25 2017/09/03 >= 1.0.16 neard-php-7.0.7-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.6 2016/04/29 2017/09/03 >= 1.0.16 neard-php-7.0.6-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.5 2016/03/30 2017/09/03 >= 1.0.16 neard-php-7.0.5-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.3 2016/02/04 2017/09/03 >= 1.0.16 neard-php-7.0.3-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.2 2016/01/06 2017/09/03 >= 1.0.16 neard-php-7.0.2-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
7.0.0 2015/12/03 2017/09/03 >= 1.0.16 neard-php-7.0.0-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.32 2017/10/26 2017/11/20 >= 1.0.16 neard-php-5.6.32-r22.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.31 2017/07/06 2017/09/03 >= 1.0.16 neard-php-5.6.31-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.30 2017/01/19 2017/09/03 >= 1.0.16 neard-php-5.6.30-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.29 2016/12/08 2017/09/03 >= 1.0.16 neard-php-5.6.29-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.28 2016/11/09 2017/09/03 >= 1.0.16 neard-php-5.6.28-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.26 2016/09/19 2017/09/03 >= 1.0.16 neard-php-5.6.26-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.23 2016/06/22 2017/09/03 >= 1.0.16 neard-php-5.6.23-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.22 2016/05/26 2017/09/03 >= 1.0.16 neard-php-5.6.22-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.21 2016/04/28 2017/09/03 >= 1.0.16 neard-php-5.6.21-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.20 2016/04/01 2017/09/03 >= 1.0.16 neard-php-5.6.20-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.18 2016/02/04 2017/09/03 >= 1.0.16 neard-php-5.6.18-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.17 2016/01/06 2017/09/03 >= 1.0.16 neard-php-5.6.17-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.16 2015/11/26 2017/09/03 >= 1.0.16 neard-php-5.6.16-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.14 2015/10/01 2017/09/03 >= 1.0.16 neard-php-5.6.14-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.8 2015/04/16 2017/09/03 >= 1.0.16 neard-php-5.6.8-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.6.0 2014/08/28 2017/09/03 >= 1.0.16 neard-php-5.6.0-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.5.38 2016/07/20 2017/09/03 >= 1.0.16 neard-php-5.5.38-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.5.37 2016/06/23 2017/09/03 >= 1.0.16 neard-php-5.5.37-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.5.36 2016/05/25 2017/09/03 >= 1.0.16 neard-php-5.5.36-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.5.35 2016/04/28 2017/09/03 >= 1.0.16 neard-php-5.5.35-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.5.34 2016/03/30 2017/09/03 >= 1.0.16 neard-php-5.5.34-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.5.32 2016/02/04 2017/09/03 >= 1.0.16 neard-php-5.5.32-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.5.31 2016/01/06 2017/09/03 >= 1.0.16 neard-php-5.5.31-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.5.30 2015/10/01 2017/09/03 >= 1.0.16 neard-php-5.5.30-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.5.24 2015/04/16 2017/09/03 >= 1.0.16 neard-php-5.5.24-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.5.16 2014/08/21 2017/09/03 >= 1.0.16 neard-php-5.5.16-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.5.14 2014/06/26 2017/09/03 >= 1.0.16 neard-php-5.5.14-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.5.10 2014/03/06 2017/09/03 >= 1.0.16 neard-php-5.5.10-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.4.45 2015/09/03 2017/09/03 >= 1.0.16 neard-php-5.4.45-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.4.40 2015/04/16 2017/09/03 >= 1.0.16 neard-php-5.4.40-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.4.31 2014/07/24 2017/09/03 >= 1.0.16 neard-php-5.4.31-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.4.30 2014/06/26 2017/09/03 >= 1.0.16 neard-php-5.4.30-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.4.26 2014/06/26 2017/09/03 >= 1.0.16 neard-php-5.4.26-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.4.16 2013/06/06 2017/09/03 >= 1.0.16 neard-php-5.4.16-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.3.29 2014/08/14 2017/09/03 >= 1.0.16 neard-php-5.3.29-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.3.28 2013/12/12 2017/09/03 >= 1.0.16 neard-php-5.3.28-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.3.13 2012/05/08 2017/09/03 >= 1.0.16 neard-php-5.3.13-r21.7z [MD5] [SHA1] [SHA256] [SHA512]
5.2.17 2011/01/06 2017/09/03 >= 1.0.16 neard-php-5.2.17-r21.7z [MD5] [SHA1] [SHA256] [SHA512]

View all releases