Where is the source code of neard.exe ?

neard.exe is based on Aestan Tray Menu 1.6.2.
You can download the source code here : aetraymenu_src.zip
Neard uses the exe and the ini file to generate the tray menu.

How to upgrade from a previous release ?

Neard is a portable application and does not provide a setup at this time.
To upgrade from a previous release, you have to follow the instructions in the Upgrade notes page.

Why Neard icon in the system tray is yellow or red ?

Neard icon has 3 states :

  • : All enabled services are started
  • : One or more enabled services are stopped
  • : All enabled services are stopped

To check from the Services Manager, click Start > Run and type services.msc and check the status of Neard* services :

Warning icon in Apache / PHP versions menu ?

Apache 2.4.20 does not seem to be compatible with PHP 5.2.17

The error message explains himself why you have a warning icon when you want to switch version.
Please read Apache compatibility table page.

What is the default password for root user on MySQL / MariaDB ?

By default, there is no password for root user.

How to use MySQL and MariaDB simultaneously with PHP ?

By default MySQL is started on port 3306 and MariaDB on port 3307.
Here is an example using PDO to access a database named wordpress installed on MySQL and MariaDB :

$mysql = new PDO('mysql:host=127.0.0.1;port=3306;dbname=wordpress', 'root', '');
$mysqlStmt = $mysql->query("SELECT * FROM wp_comments");
var_dump($mysqlStmt->fetchAll(PDO::FETCH_ASSOC));

$mariadb = new PDO('mysql:host=127.0.0.1;port=3307;dbname=wordpress', 'root', '');
$mariadbStmt = $mariadb->query("SELECT * FROM wp_comments");
var_dump($mariadbStmt->fetchAll(PDO::FETCH_ASSOC));

What is the default user / password on PostgreSQL ?

The user is postgres and there is no password for this user.

PostgreSQL start gives FATAL: role does not exist

When PostgreSQL is started as a service, you can have this error :

LOG:  database system was shut down at 2013-06-13 00:54:33 UTC
LOG:  autovacuum launcher started
LOG:  database system is ready to accept connections
FATAL:  role "John" does not exist
 done
server started

This happens when you run pg_ctl start with the -w (wait) option like Neard, because it will try a test connection with a user that does not exist (in your case).
But that’s not really a problem (except for the confusing error message), because that proves that the server is up.

What is the default user / password for FileZilla Server ?

The user is root and there is no password for this user.

What is the default admin port for FileZilla Server ?

14147

How to disable some services to launch on startup ?

There are two ways to disable some services to launch on startup.

First you can edit the neard.conf file and change the value to 0 for keys ending with enable = "1" below BINS.
Example: filezillaEnable = "0"

Or you can go to the Neard menu.
Example: Neard tray menu > FileZilla > Enable / Disable

A service will not start and does not display error via the menu

Aestan Tray Menu built in service manager is not handled by Neard in the Service menu :

You can take look to the Windows Event Log to find out where the error occurred or use the Debug menu of the service (like Apache, MySQL or MariaDB).

GitList - No repositories

When you go to GitList you probably get this message :

Please, edit the config file and provide your repositories directory

By default Neard seek repositories in :

  • www directory
  • C:\gitRepos

If you have others folders to scan for repositories, you have to edit the file tools\git\gitx.x.x\repos.dat then refresh repositories :

WebSVN - No repositories

When you go to WebSVN you probably get this message :

Please set up a repository in include/config.php using $config->parentPath or $config->addRepository. See the installation guide for more details.

By default Neard seek repositories in your SVN binary folder.
Example : C:\neard\bin\svn\svn1.7.19\repos

Could not execute menu item (internal error)

Could not execute menu item (internal error)
[EAccessViolation] Access violation at address XXXXXXXX in module ‘neard.exe’. Read of address XXXXXXXX

Neard tray icon is based on Aestan Tray Menu.

There are several cases to reproduce this error :

  • Execute multiple actions at the same time.
  • Do not wait for an action ends.
  • A procedure error with Neard based on neard.ini file.

For the last case you will have to create an issue.

http.exe missing MSVCR100.dll

The program can’t start because MSVCR100.dll is missing from your computer. Try reinstalling the program to fix this problem.

This error occurs because you probably have not installed the latest Neard Prerequisites Package.

Apache error 41d

Apache x.x.x (neardapache) service cannot be installed :
- Cannot start the service : Error 41d (1053 : )
- Conf errors detected :

See http.exe missing MSVCR100.dll

Apache status 1

Apache x.x.x (neardapache) service cannot be installed :
- Cannot start the service : Status 1 (1 : The service is not running)

This problem could appear on Windows XP on the first launch of Neard.
In this case, you must restart your computer.

Unable to load dynamic library php_imagick.dll

PHP Startup: Unable to load the dynamic library php_imagick.dll

See http.exe missing MSVCR100.dll

Neard has encountered a problem

Neard has encountered a problem and needs to close. We are sorry for the inconvenience.

This problem could appear on Windows XP.
You have to install the latests Neard Prerequisites Package.

FileZilla Server.exe is not a valid Win32 application

FileZilla Server.exe is not a valid Win32 application.

This problem could appear on Windows XP.
Filezilla drops Windows XP support since 0.9.43 version.
You have to download the 0.9.42 version. See Filezilla page.

php.exe - Entry point not found

The procedure entry point ReleaseSRWLockExclusive could not be located in the dynamic link library KERNEL32.dll

Most often reason to happen such error is you trying to set not thread safe extension in your PHP installation.
On Neard PHP is installed as Thread Safe.

Can’t change import file size limit in phpMyAdmin

The changes have to be done in the alias configuration in alias\phpmyadmin.conf :

<Directory "C:/neard/apps/phpmyadmin/phpmyadmin4p3/4.4.15.6/">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
    # START switchOnline tag - Do not replace!
    Order Deny,Allow
    Deny from all
    Allow from 127.0.0.1 ::1
    # END switchOnline tag - Do not replace!
    
    <IfModule php5_module>
        php_admin_value upload_max_filesize 128M
        php_admin_value post_max_size 128M
        php_admin_value max_execution_time 360
        php_admin_value max_input_time 360
    </IfModule>
    <IfModule php7_module>
        php_admin_value upload_max_filesize 128M
        php_admin_value post_max_size 128M
        php_admin_value max_execution_time 360
        php_admin_value max_input_time 360
    </IfModule>
</Directory>

Skype conflict port 80 and 443

To turn off and disable Skype usage of and listening on port 80 and port 443, open the Skype window, then click on the Tools menu and select Options. Click on the Advanced tab, and go to the Connection sub-tab. Untick or uncheck the checkbox for Use port 80 and 443 as an alternative for additional incoming connections option. Click on the Save button and then restart Skype to make the change effective.

IIS conflict port 80 and 443

Open a CMD prompt (as Admin) and type iisreset /stop

Or you can change the port number of IIS by following the official Microsoft documentation.

PATH env. var is not resolved by Apache service

Services loaded with NSSM have the PATH environment variable rewritten.
Impacted services are : Apache, MailHog and Memcached.

For each of these services the item Update env. PATH is available in the Neard’s tray menu to add new paths to the PATH environment variable (one by line).

As you can see you can add paths relative to the Neard root folder (eg. www).

After the modifications have been made, restart Neard for the changes to take effect.

In the phpinfo the Apache environment will look like this :

And as you can see some paths are automatically added :

  • %SystemRoot%\system32
  • %SystemRoot%
  • %SystemRoot%\system32\Wbem
  • %SystemRoot%\system32\WindowsPowerShell\v1.0
  • NEARD_PATH\bin\apache\apache*\bin
  • NEARD_PATH\bin\php\php*
  • NEARD_PATH\bin\php\php*\pear
  • NEARD_PATH\bin\php\php*\imagick
  • NEARD_PATH\bin\nodejs\nodejs*
  • NEARD_PATH\bin\svn\svn*
  • NEARD_PATH\tools\composer\composer*
  • NEARD_PATH\tools\drush\drush*
  • NEARD_PATH\tools\git\git*\bin
  • NEARD_PATH\tools\imagemagick\imagemagick*
  • NEARD_PATH\tools\phpmetrics\phpmetrics*
  • NEARD_PATH\tools\phpunit\phpunit*
  • NEARD_PATH\tools\python\python*\bin
  • NEARD_PATH\tools\ruby\ruby*\bin
  • NEARD_PATH\tools\wpcli\wpcli*

Service cannot start on Windows 10 Creators Update

Since the Windows 10 Creators Update Apache, MailHog and Memcached cannot start (Issue #242) :

This bug comes from services started with the Non-Sucking Service Manager which try to create a console window. The workaround is to configure the service not to open a console window.
You can download the hotfix for Neard 1.0.22 here :

This issue is solved for Neard 1.2 and higher.

Windows XP limitation

  • Filezilla drops Windows XP support since 0.9.43 version.
  • Starting in version 2.2, MongoDB does not support Windows XP. Version 2.6 seems to work but is not supported.
  • Node.js drops Windows XP and Vista support since 6.0 version.
  • Git drops Windows XP support since 2.10.0 version.
  • Python drops Windows XP support since 3.4.3 version.
  • Ruby is not supported on Windows XP since 2.1 version.

Invalid argument - ruby_setenv(ALLUSERSPROFILE)

If you’ve got this kind of error with Ruby :

C:/neard/tools/ruby/ruby2.3.3.p222/lib/ruby/gems/2.3.0/gems/bundler-1.14.6/lib/bundler.rb:20:in `replace': Invalid argument - ruby_setenv(ALLUSERSPROFILE) (Errno::EINVAL)
  from C:/neard/tools/ruby/ruby2.3.3.p222/lib/ruby/gems/2.3.0/gems/bundler-1.14.6/lib/bundler.rb:20:in `<module:Bundler>'
  from C:/neard/tools/ruby/ruby2.3.3.p222/lib/ruby/gems/2.3.0/gems/bundler-1.14.6/lib/bundler.rb:17:in `<top (required)>'
  from C:/neard/tools/ruby/ruby2.3.3.p222/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
  from C:/neard/tools/ruby/ruby2.3.3.p222/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
  from C:/neard/tools/ruby/ruby2.3.3.p222/lib/ruby/gems/2.3.0/gems/bundler-1.14.6/exe/bundle:12:in `<top (required)>'
  from C:/neard/tools/ruby/ruby2.3.3.p222/bin/bundle:22:in `load'
  from C:/neard/tools/ruby/ruby2.3.3.p222/bin/bundle:22:in `<main>'

You will need to restart your computer.
If you’ve got more information about this error, please post an issue.

Ruby : MSYS2 could not be found

Since Ruby 2.4, RubyInstaller is based on MSYS2 toolchain. If you want to compile C based ruby gems, you will have to download and install all necessary MSYS2 build tools by typing the command ridk install used by the official installer.

Ghostscript : How to use Windows TrueType fonts for Chinese, Japanese and Korean ?

To update lib/cidfmap with the common CJK fonts provided by Microsoft products, launch the script update_cidfmap.bat in the root folder of Ghostscript.